Как сделать календарь на месяц

Добавлено: 30.09.2018, 19:49 / Просмотров: 42384

Закрыть ... [X]

трюки•приёмы•решения

Примеры формул 07.04.2013 11026

Эта статья содержит информацию о том, как создать «живой» календарь в диапазоне ячеек (рис. 110.1). Если вы измените дату, которая отображается в верхней части календаря, произойдет пересчет и календарь выведет даты для месяца и года.

Рис. 110.1. Этот календарь был создан с помощью составной формулы массива

Рис. 110.1. Этот календарь был создан с помощью составной формулы массива

Для создания этого календаря в диапазоне ячеек В2:Н9 выполните следующие действия.

  1. Выберите ячейки В2:Н2, а затем объедините их с помощью команды Главная ► Выравнивание ► Объединить и поместить в центре.
  2. Введите дату в объединенный диапазон. День месяца не важен, так что можете изменить формат ячейки на пользовательский формат, который не отображает день: ММММ, ГГГГ.
  3. Введите сокращенные названия дней в диапазон В3:Н3.
  4. Выберите В4:Н9, а затем введите следующую формулу массива без разрывов строк. Помните: чтобы ввести формулу массива, нажмите Ctrl+Shift+Enter (а не просто Enter):
    =ЕСЛИ(МЕСЯЦ(ДАТА(ГОД(B2);МЕСЯЦ(B2);1))<>МЕСЯЦ(ДАТА(ГОД(B2);МЕСЯЦ(B2);1)-(ДЕНЬНЕД(ДАТА(ГОД(B2);МЕСЯЦ(B2);1)+{0:1:2:3:4:5}7+{1;2;3;4;5;6;7}-1);"";ДАТА(ГОД(B2);МЕСЯЦ(B2);1)-(ДЕНЬНЕД(ДАТА(ГОД(B2);МЕСЯЦ(B2);1)+{0:1:2:3:4:5}7+{1;2;3;4;5;6;7}-1)))))
  5. Отформатируйте диапазон В4:Н9, задав для него числовой формат, в котором отображается только день: Д.
  6. Отрегулируйте ширину столбцов и отформатируйте ячейки так, как вам нравится.

Измените дату и год, и календарь обновится автоматически. После создания этого календаря вы можете скопировать диапазон ячеек в любой другой лист или книгу.

По теме

Новые публикации

    Яндекс.Метрика

Excelexpert.ru — небанальное руководство для пользователей Microsoft Excel. Материалы предназначены для пользователей, которые владеют начальными навыками работы с Excel, и при этом понимают, что им еще необходимо многому научиться, чтобы в полной мере использовать для своих нужд и потребностей необычайно широкие возможности многофункционального инструмента под названием Microsoft Excel. Материалы сайта насчитывают более 200 профессиональных трюков, приемов и советов. Легкая и непринужденная форма изложения материалов и никакой сухой теории - исключительно реально применяемые способы на практике.

Top


Источник: http://excelexpert.ru/kak-sozdat-kalendar-v-tablice-excel-pri-pomoshhi-formuly-massiva

Похожие новости


Поливная система на даче своими руками
Как по руке узнать имя своего мужа
Как в террарии сделать святой слиток
По чертежам сборка садовой мебели своими руками
Нет развала колес как сделать
Как похудеть в домашних условиях что нужно есть
Как сделать интернет доступ только на один сайт
Как сделать свой советник




ШОКИРУЮЩИЕ НОВОСТИ


Back to Top